PHP is one of the most commonly used curly-bracket programming languages. It is pretty popular since it is free software, which you can use to build responsive sites like social networking websites, e-shops or school websites rather than static HTML sites. A PHP module should be installed on the server where a PHP-powered site is hosted so that its source code can be ‘deciphered’. As there are no license taxes for this sort of module and the language itself provides endless possibilities for the web-based apps that you set up, there are 100s of millions of PHP-driven sites. On top of that, there are heaps of PHP-based scripts, which you can use for your websites without needing to have any programming know-how. As there’re several PHP versions, you have to check if the same exact version that you used whilst developing your website is present on the web server as well.
PHP 4 and PHP 5 Support in Cloud Website Hosting
We’ve reached a decision not to restrict our present and future clients from choosing the PHP version that their sites will be using, which implies that in case you buy a cloud website hosting package from our company, you will be able to pick between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the account as a whole, but also for each single domain name hosted by you. This can be accomplished with only one single mouse click from our custom-built Hepsia Control Panel via which all shared hosting accounts are managed, which is why you will not have to possess any coding or technical capabilities. You’ll be able to run sites built with both old and new PHP-based scripts without having to overcome any obstacles, so if you decide to drop your current hosting services provider and switch over to us, you can be certain that all the sites that you have created through the years will continue to work properly.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Our semi-dedicated plans support multiple PHP versions, so you will be able to use all the web-based applications that you have developed throughout the years. The Hepsia Control Panel, which comes with every single semi-dedicated account, will enable you to enable the required version with one single click of the mouse. You can choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. If you would like to host multiple sites under the very same account and they have different requirements in regard to the web hosting platform, you will be able to set a different PHP version for each of them irrespective of which version is selected for the account as a whole. This is achievable owing to our in-house developed cloud web hosting platform, which allows us to run different PHP versions concurrently. By comparison, most web hosting vendors normally support one, maximum two versions.